
Tutorial 1 
Introduction to LibreCAD 

INTRODUCTION 
CAD – Computer Aided Design tool. A tool to make things better. 

The following topics are covered in this tutorial. 

• What is CAD? 
• How can artisans integrate CAD? 
• Which software should we use? 
• Real world exercises 
• Homework 
• Wrap up and recap 

CAD & ARTISANS 
How can artisans integrate CAD in our daily work? There is no substitute for handmade craft. 

But: 

• we can use CAD to design without limits, 
• we can preview the final results and predict real problems, 
• we can get higher precision than using hand tools, 
• we can achieve more repeatable results, 
• and CAD provides a path to CAM (Computer Aided Manufacturing) such CNC, 3D printer, or a 

laser. 
 

All of these must be directed by the skills of the artisan. Using only the technical tools will result in 
failure. 

LIBRECAD – WHY? 
It is the perfect tool for a new user. It is: 

• Free and open source 
• Powerful and stable 
• Forces a good methodology and encourages learning best practices – it forces you to do things 

in the right way 
• Developed and updated by the community – the user decides the features 
• Covers 99% of the needs of the artisan 

TUTORIAL 1 – DRILLING TEMPLATE FOR BRIDGES 
The requirements are: 

• 11.7mm string spacing at the saddle – requested by customer 
• Tie block width is 80mm 
• Wings of the bridge are 4mm 
• Minimum string height is 10mm 



• Drill holes are 1mm 

Tutorial Steps 
Overview 

1. Open LibreCAD 
2. If this is the first time using LibreCAD: 

a. Select default units of mm or inches – mm 
b. Select language for user interface – English 

3. The main working area is the black box 
4. Presentation demonstrated opening an existing design using the File->Open menu and then 

zooming in and out using the wheel on the mouse and moving (panning) the drawing using by 
pressing the wheel. Then File->Close 

5. There are two coordinate systems. Absolute and relative. 
6. Move the mouse around and notice that the mouse position is displayed in the lower left corner 

of the screen in two different columns. The numbers in the left column is the position of the 
cursor with respect to the origin (shown as a red cross on the screen). The numbers in the right 
column are with respect to the relative zero position (shown as a small circle with a cross in 
it). The following picture shows the absolute and relative positions of the cursor. 

 

7. Creating items in the drawing can be done using the Tools menu, the Toolbar on the left, or by 
typing commands in Command line entry field on the lower right. 

8. The Command line tool in the lower right has a transcript window in it that is used to display 
commands you type, below that is a command prompt indicating what is expected for the next 
input by LibreCAD (currently set to Command: ), and below that is the entry field where you can 
type commands and other information required by the commands. See figure below for an 
example. 



 

Create a horizontal line which is the bottom of the tie block. 
1. To Create the line, select the first item in the left toolbar. This displays a list of line types that 

can be created. Choose the Horizontal menu item to create a horizontal line. 
2. The tool is now in a mode that can be used to create a horizontal line. 
3. The lower right Command line tool now has the prompt Specify position. 
4. In the top toolbar under the menus there is displayed a set of properties for the line. The Snap 

Point specifies how the position you specify is used to create the line. The setting in the image 
below has the position entered specified to be the Start point of the line. Other options are the 
Middle and End points. The Length can be used to specify how long a line to draw. 

 

5. Enter 80 into the Length entry field which is the length of the tie block. Set the Snap Point to 
Start. 

6. Use the Absolute origin as the lower left of the tie block. It is a good practice for the absolute 
origin to be a key point on the object you are creating. 

7. Enter 0,0 in the Command line entry field.  
8. A horizontal line that is 80 mm long and starts at the absolute origin is now drawn. 

Create a vertical line at right end of the tie block. 
1. Select the Vertical menu item from the Line menu. 
2. Set the length to 10mm which is the thickness of the bridge. 
3. To create the line we want to have it start at the end of the horizontal line. Doing this using the 

mouse will result in a gap in the line. To make this easy the Snap options can be used. 
4. There is a toolbar below the drawing area that contains a number of different options for how 

the point entered by the mouse is used. These are (from 
https://librecad.readthedocs.io/en/latest/ref/snaps.html): 

https://librecad.readthedocs.io/en/latest/ref/snaps.html


• Exclusive Snap Mode – On: only one snap mode is allowed. Off: multiple snap modes 
are allowed. 

• Free Snap – Allows for the crosshair to move freely while other snap modes are 
enabled. If this is off, then it is very easy to see the snap for each of the other modes. 

• Snap on Grid – Snap to a grid intersection. 
• Snap on Endpoints – Snap to the endpoints of a line segment, the quadrants of a circle, 

a point, or the alignment point of a text or mtext object. 
• Snap on Entity – Snap to the path of an entity. 
• Snap on Center - Snap to the center of a circle or ellipse. It will also snap to the foci of 

an ellipse. 
• Snap Middle - Snap to the middle of a path. Enabling this mode displays a ‘’Middle 

points’’ input. If you change the value to 2 then you can snap to the trisection points 
of a line segment. 

• Snap Distance - If you snap to the endpoint of a line segment then activate ‘’snap 
distance’’ and input 50, then it will snap to a point 50 units from the endpoint on the 
line segment. However, it will also snap to a point that is 50 units from the other 
endpoint. 

• Snap Intersection - Snap to the intersection of two entities. Note this does not currently 
work for polylines. 

• Restrict Horizontal – Restricts the crosshairs to the x-axis (horizontal movement). 
• Restrict Vertical – Restricts the crosshairs to the y-axis (vertical movement). 
• Restrict Orthogonal – Restricts the crosshairs to the x or y-axis. (either horizontal or 

vertical movement) -  
• Set relative zero position – Manually sets the Relative Zero Point at the selected 

coordinate. 
• Lock relative zero position - Locks the Relative Zero Point to the current coordinate. 

 

5. Select Free Snap and Snap on Endpoints (they should both be highlighted). 
6. Move the cursor near to the end of the horizontal line and click the left mouse button. This will 

create the vertical line with its start point coincident to the end point of the horizontal line. 

Create a vertical line at left end of the tie block. 
1. Click the right mouse button to clear the vertical line creation mode. 
2. We will use the command line to create the next line. 
3. Press Ctl-G to remove the display of the grid. 
4. We need to draw a line from 0,0 to 0,10. 
5. In the Command line entry field type: line. This sets the line creation mode and the Command 

line prompt indicates Specify first point. 
6. Next enter 0,0 (the start point of the line). 
7. Next enter 0,10 (the end point of the line). 
8. Click the right mouse button to end the line entry mode. 

Create a horizontal line at the top of the tie block 
1. Verify that the relative zero position is at the end of the left vertical line. 



2. We will create a line using relative positions instead of absolute positions using the @ notation 
for position. 

3. Select 2 Points menu item from the Line menu. 
4. Type @0,0 in the Command line entry field to specify the first position being at the relative zero 

position. 
5. Type @80,0 in the Command line entry field to specify the second position being at 80 x offset 

and 0 y offset from the relative zero position. 
6. Click the right mouse button to end the line entry mode. 
7. There are many ways to enter positions as we have seen: absolute position and relative 

position in the command line entry field and using the mouse with various snap settings. 

Create axis and reference lines 
Now create axis and reference lines to provide guidance on where the drill holes go. 

Select Snap Middle so that we can snap to the middle of a line. The top toolbar now has a Middle 
Points field that specifies how many snap points are in the line. The default is that there is one snap 
point ½ way between the two end points. If you change that to 2 then there are 2 snap points between 
the end points, to 3 provides 3 snap points. You can experiment with this. 

1. Make sure the Middle Points field is set to 1. 
2. Select 2 Points menu item from the Line menu. 
3. Click near the middle of the lower line and then the middle of the upper line to draw a vertical 

axis line. Click the right mouse button to clear the mode or finish with the tool. 

The reference line is 4 mm above the bottom of the tie block or the top of the wings. To create this, we 
will use the Modify->Offset menu item to create a line that is 4 mm above the horizontal line. 

1. Select the lower horizontal line (bottom of the tie block) 
2. Select the Tools->Modify->Offset menu 
3. Enter 4 in the Distance entry field that has appeared in the upper toolbar. 
4. Move the cursor near the horizontal line on the side of the line that you want the new line to 

be place (above the lower line) and press the left mouse button. 
5. Press the ESC key to clear the node or finish the command. 

An alternate is to type offset in the Command line entry field, enter 4 in the Distance entry field, and 
then click on the side of the line you want the new line to be placed. 

These lines are meant to be guidelines and not part of the object we are creating. Using layers allows 
us to separate these lines and define what they are meant to represent. On the right-hand side of the 
drawing there is a tool that is labeled Layer List (in the following image). We will create the Axis layer. 

1. Select the + in Layer List tool. 
2. In the form that is displayed: 

a. Set the Layer Name to Axis 
b. The Color to Red 
c. The Width to 0.13mm (ISO) 
d. The Line Type to Dash (small). 

3. Press OK to create the layer 

 



 

Next the guidelines need to be moved to the Axis layer. 

There are several ways to select multiple items. 

• The first is to just select each item – the item becomes dashed when selected. 
• Pressing the left mouse and dragging it to the lower right creates a blue rectangle. Anything 

that is completely inside the box will be selected. 
• Pressing the left mouse and dragging it to the upper left creates a green rectangle. Anything 

that is contained or intersects the box will be selected. 
 

1. Use one of these methods to select the axis and reference lines 
2. Select Tools->Modify->Attributes and change the Layer attribute to Axis and press OK. 

Layer Settings can be changed using the icon on the far right of the + in the Layer List tool.  

1. Select the Axis layer in the Layer List tool. 
2. Press the icon on the far right of the + in the Layer List tool. 
3. In the form change the Line Type to Dash(tiny) and select OK. 
4. All items on the Axis layer now show the new setting. 

Create guidelines for each of the drill holes 
Use the offset command to create a line on each side of the center axis. This offset is ½ of the string 
spacing. 

1. Type offset in the Command line entry field. 
2. Type 11.7/2 in the Command line entry field. The Distance entry in the upper toolbar is now 

set to 5.85. 
3. Move the cursor close to the axis line and create a line on each side. 
4. Using the offset command create an offset of 11.7 and 4 more lines. 

Create drill holes 
1. Select Layer 0 in the Layer List tool. 



2. Select Snap Intersection in the lower tool bar. 
3. Select Tools->Circle->Center,Radius 
4. Enter 1mm in the Radius entry field in the upper toolbar. 
5. Click on the 6 intersections where you want the drill holes. 

Add Dimensions 
Place all of the dimensions on the drawing in the Dimensions layer. 

1. Create a new layer named Dimensions that is Blue, 0.13mm (ISO), and Continuous 
2. Select Tools->Dimension->Horizontal 
3. Select the 2nd intersection from the right and then the 1st intersection from the right 
4. Move the dimension to where you want it placed and click (you may need to turn off all snaps 

but the Free Snap to place it in an arbitrary position). 
5. Finish the command. 
6. To change the precision of the dimension displayed use the Options->Current Drawing 

Preferences menu item. 
a. Select the Dimensions Tab. 
b. Set the Linear Precision to 0.00. 
c. Click OK 

7. Create a vertical dimension on the right-hand side. 
8. Create a horizontal dimension on the bottom. 

Completed Design 
The following is the completed design. 

1. Save the design using the File->Save menu item and give it a name and place it wherever you 
wish. 

 

 

TUTORIAL 2 – RADIUS TEMPLATE 
The requirements are: 

• Radius of 5432 mm or 17.82152 ft 
• Must cover a body length of 600mm 
• Minimum thickness at center of 300mm 

Tutorial Steps 
Overview 

1. Open LibreCAD 
2. Create new design 



3. Remove the grid – Ctl-G or use Grid Button on upper toolbar 

Create the bottom line of the template 
1. Select Line->Horizontal line from the Tools toolbar. 
2. Set the Length to 600mm 
3. Set the Snap Point to Middle 
4. Type 0,0 in the Command line entry field 

Create layers 
1. Axis –Color: yellow, Width: 0.13mm ISO, Line type: Continuous 
2. Dimensions – Color: blue, Width: 0.13mm ISO, Line type: Continuous 

Create Axis 
The axis is a 30 mm line from the center of the lower line of the template 

1. Select the Axis layer 
2. Create Line->2 Points line 
3. Enter 0,0 in the Command line entry field 
4. Enter 0,30 in the Command line entry field 
5. Finish the line 

Create upper curved line of template 
The curved part of the template will be an arc that is 5432mm that extends beyond each end of the 
horizontal line at the bottom of the template. 

1. Select layer 0 
2. Select the Curve->Center, Point, Angles option from the Tools toolbar 
3. Specify the center of the curve as 0,30+5432 in the Command line entry field 
4. Specify the radius of the as 5432 in the Command line entry field 
5. Select a point to the left of the left end of the lower horizontal line of the template 
6. Select a point to the right of the right end of the lower horizontal line of the template 
7. End the command 

Create right and left vertical lines of template 
1. Set the Snap on Endpoints in the lower toolbar (remove other snaps besides Free Snap) 
2. Select the Line->2 Points line 
3. Select the first point of the left vertical line as the left end of the lower horizontal line 
4. Set the Restrict Vertical in the lower toolbar 
5. Select the second point of the left vertical line to a point above curved line 
6. Clear the Restrict Vertical in the lower toolbar so that the mouse can move to the other end of 

the line 
7. Type line in the Command line entry field 
8. Set the first point of the right vertical line as the right end of the lower horizontal line by clicking 

on the end of the line 
9. Set the second point of the right vertical line using a relative position by typing @0,60 in the 

Command line entry field 
10. End the command (right mouse or escape key) 

Trim the vertical and curved lines 
1. Select Tools->Modify->Trim 
2. Select the “knife” or limiting entity by clicking the curved line 
3. Select the portion of the right vertical light below the curve (the portion to be kept) 



4. Type trim in the Command line entry field 
5. Select the “knife” or limiting entity by clicking the right vertical line 
6. Select the portion of the curved line to the left of the right vertical line 
7. End the command 
8. Select the Tools->Modify->Trim Two 
9. Select the portion of the curved line to keep 
10. Select the portion of the left vertical line to keep 
11. End the command 

Add Label and Dimensions 
1. Select the Dimensions layer 
2. Select Tools->Dimensions->Horizontal 
3. Select the lower left corner of the template 
4. Select the lower right corner of the template 
5. Use the Tools->Dimensions->Vertical to create a dimension of the axis line showing the 

minimum width of the template 
6. Create a label by selectin the Tools->MText (multi-line text) 
7. Enter the text Template R 2432mm in the Text entry of the popup form 
8. Set the height of the text to 10mm by entering 10 in the Height entry field of the popup form 
9. Click the OK button in the popup form 
10. Place the text using the cursor in the left portion of the template 
11. End the command 
12. Set the Linear Precision to 0.00 and the Text Height to 5 in the Options->Current Drawing 

Preferences form and press OK 

Completed Design 
The following is the completed design. 

1. Save the design using the File->Save menu item and give it a name and place it wherever you 
wish. 

 

HOMEWORK 
Make a Headstock template. Use the origin as the center bottom of the headstock. Adapt to your 
design. Use the main, Axis, and Dimensions layers. Export the file as PDF using the File->Export->Export 
as PDF menu item. The following discussion assumes you have the headstock as your active drawing. 

1. To setup the page use File->Print Preview. This displays the drawing that page it will be printed 
upon. 

2. The entry field in the upper toolbar shows the scale used and by default it is set so that the 
drawing fits on the current paper. Set this value to 1:1 (so that the drawing is not scaled). You 
may have to unset the fixed checkbox in order to change the value in the entry field. 

3. Select the fixed check box. This removes the option to resize the drawing to the page (Fit to 
Page button is removed). 



4. To change the paper size and orientation use the Options->Current Drawing Preferences menu 
item and the Paper tab in the form. Select the paper you want to use (for this A4 or Letter) and 
the orientation to Portrait (so that drawing fits well on the paper). 

5. Use the Center to Page button on the upper toolbar to center the drawing on the page. You can 
also grab the “paper” and position the paper to contain the drawing. 

6. Turn off the Print Preview by selecting the File->Print Preview again (it is a toggle button). 

This will now be used when you print or export the drawing. 

The PDF file you export can be used to commercial print shop, laser printers, CNC machines, etc… 
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